aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/gpsd/0001-workaround-for-scons-using-python2.patch145
-rw-r--r--main/gpsd/APKBUILD18
-rw-r--r--main/gpsd/gpsd-use-local-timepps-header.patch4
-rw-r--r--main/gpsd/ttydefaults.patch12
4 files changed, 73 insertions, 106 deletions
diff --git a/main/gpsd/0001-workaround-for-scons-using-python2.patch b/main/gpsd/0001-workaround-for-scons-using-python2.patch
index 887d10a641..5e8e1f0976 100644
--- a/main/gpsd/0001-workaround-for-scons-using-python2.patch
+++ b/main/gpsd/0001-workaround-for-scons-using-python2.patch
@@ -1,55 +1,15 @@
-diff --git a/gpscat b/gpscat
-index 26c9acf..6cf4765 100755
---- a/gpscat
-+++ b/gpscat
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- #
- "Display GPS output. Hexify it if necessary."
-
-diff --git a/gpsfake b/gpsfake
-index e02d64a..ec10974 100755
---- a/gpsfake
-+++ b/gpsfake
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- #
- '''
- gpsfake -- test harness for gpsd
-diff --git a/ubxtool b/ubxtool
-index 6bdb0ba..82f5b2e 100755
---- a/ubxtool
-+++ b/ubxtool
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- # -*- coding: UTF-8
- '''
- ubxtool -- u-blox configurator and packet decoder
-diff --git a/zerk b/zerk
-index 745c765..2e1b73a 100755
---- a/zerk
-+++ b/zerk
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- # -*- coding: UTF-8
- '''
- zerk -- GREIS configurator and packet decoder
- diff --git a/contrib/ntpshmviz b/contrib/ntpshmviz
-index 5aa0016..371fd70 100755
+diff --git a/contrib/ntpshmviz b/contrib/ntpshmviz
+index a7ae44f..5627d3a 100755
--- a/contrib/ntpshmviz
+++ b/contrib/ntpshmviz
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
- '''
- ntpshmviz - graph the drift of NTP servers
- Written by Keane Wolter <daemoneye2@gmail.com>
+ #
+ # This file is Copyright (c) 2010-2018 by the GPSD project
+ # SPDX-License-Identifier: BSD-2-clause
diff --git a/contrib/skyview2svg b/contrib/skyview2svg
-index 7fdc327..3ed04c3 100644
+index 9c79b25..6b80d4b 100644
--- a/contrib/skyview2svg
+++ b/contrib/skyview2svg
@@ -1,4 +1,4 @@
@@ -59,7 +19,7 @@ index 7fdc327..3ed04c3 100644
"""
skyview2svg -- Create an SVG image of GPS satellites sky view.
diff --git a/contrib/webgps.py b/contrib/webgps.py
-index 99a70c6..a1bcbd2 100755
+index 902c162..942dcbb 100755
--- a/contrib/webgps.py
+++ b/contrib/webgps.py
@@ -1,4 +1,4 @@
@@ -79,7 +39,7 @@ index f269433..531a4c7 100755
# A Python AIVDM/AIVDO decoder
#
diff --git a/devtools/aivdmtable b/devtools/aivdmtable
-index c572070..89f9e0d 100755
+index 13c1e5f..51c4146 100755
--- a/devtools/aivdmtable
+++ b/devtools/aivdmtable
@@ -1,4 +1,4 @@
@@ -89,7 +49,7 @@ index c572070..89f9e0d 100755
# Generate an asciidoc table of the six-bit encoding used in AIVDM packets.
#
diff --git a/devtools/cycle_analyzer b/devtools/cycle_analyzer
-index 53ddd51..6992c10 100755
+index aac4c6c..0aa20c2 100755
--- a/devtools/cycle_analyzer
+++ b/devtools/cycle_analyzer
@@ -1,4 +1,4 @@
@@ -119,17 +79,17 @@ index ec10a84..480a3fb 100755
# This code runs compatibly under Python 2 and 3.x for x >= 2.
# Preserve this property!
diff --git a/devtools/regress-builder b/devtools/regress-builder
-index 67df358..1ea75fd 100755
+index 3266768..ef44506 100755
--- a/devtools/regress-builder
+++ b/devtools/regress-builder
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
#
- # This file is Copyright (c) 2010 by the GPSD project
+ # This file is Copyright (c) 2010-2019 by the GPSD project
# BSD terms apply: see the file COPYING in the distribution root for details.
diff --git a/devtools/regressdiff b/devtools/regressdiff
-index fa658c1..0f85a72 100755
+index 6188687..24d5f42 100755
--- a/devtools/regressdiff
+++ b/devtools/regressdiff
@@ -1,4 +1,4 @@
@@ -139,7 +99,7 @@ index fa658c1..0f85a72 100755
# Walk through a pair of textfiles looking for where they begin to differ.
# May be useful for comparing logs when regression tests break.
diff --git a/devtools/sizes b/devtools/sizes
-index b8afa6e..11e39ab 100755
+index f6459cf..05a5fb7 100755
--- a/devtools/sizes
+++ b/devtools/sizes
@@ -1,4 +1,4 @@
@@ -149,7 +109,7 @@ index b8afa6e..11e39ab 100755
# sizes -- explore the sizes of static gpsd binaries
#
diff --git a/devtools/striplog b/devtools/striplog
-index 5c63dda..70d41ad 100755
+index e81a2c8..4ba3cbd 100755
--- a/devtools/striplog
+++ b/devtools/striplog
@@ -1,4 +1,4 @@
@@ -189,7 +149,7 @@ index e78d412..916fbab 100755
# This code runs compatibly under Python 2 and 3.x for x >= 2.
# Preserve this property!
diff --git a/gegps b/gegps
-index 51af633..945e730 100755
+index 8672e7e..0c1b53e 100755
--- a/gegps
+++ b/gegps
@@ -1,4 +1,4 @@
@@ -199,7 +159,7 @@ index 51af633..945e730 100755
'''
usage: gegps [-i] [-d kmldir]
diff --git a/gps/gps.py b/gps/gps.py
-index 7835c5e..f0ed6f4 100644
+index c3f4a03..5956eec 100644
--- a/gps/gps.py
+++ b/gps/gps.py
@@ -1,4 +1,4 @@
@@ -208,8 +168,28 @@ index 7835c5e..f0ed6f4 100644
# -*- coding: utf-8 -*-
'''gps.py -- Python interface to GPSD.
+diff --git a/gpscat b/gpscat
+index c04dc72..0035316 100755
+--- a/gpscat
++++ b/gpscat
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ "Display GPS output. Hexify it if necessary."
+
+diff --git a/gpsfake b/gpsfake
+index 6bae262..485fea6 100755
+--- a/gpsfake
++++ b/gpsfake
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ '''
+ gpsfake -- test harness for gpsd
diff --git a/gpsprof b/gpsprof
-index 2f0c60e..a8715b3 100755
+index 9bd665c..3989627 100755
--- a/gpsprof
+++ b/gpsprof
@@ -1,4 +1,4 @@
@@ -219,7 +199,7 @@ index 2f0c60e..a8715b3 100755
'''
Collect and plot latency-profiling data from a running gpsd.
diff --git a/jsongen.py b/jsongen.py
-index db4b871..ed0fde7 100755
+index e27eeb6..4788458 100755
--- a/jsongen.py
+++ b/jsongen.py
@@ -1,4 +1,4 @@
@@ -228,18 +208,8 @@ index db4b871..ed0fde7 100755
#
# This file is Copyright (c) 2010 by the GPSD project
# SPDX-License-Identifier: BSD-2-clause
-diff --git a/leapsecond.py b/leapsecond.py
-index aa5a80c..5fc657e 100755
---- a/leapsecond.py
-+++ b/leapsecond.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Usage: leapsecond.py [-v] { [-h] | [-f filename] | [-g filename]
diff --git a/maskaudit.py b/maskaudit.py
-index d5cdff9..bcdaeed 100755
+index 00d1275..2029494 100755
--- a/maskaudit.py
+++ b/maskaudit.py
@@ -1,4 +1,4 @@
@@ -248,18 +218,8 @@ index d5cdff9..bcdaeed 100755
#
# This file is Copyright (c) 2010 by the GPSD project
# SPDX-License-Identifier: BSD-2-clause
-diff --git a/test_maidenhead.py b/test_maidenhead.py
-index 665fd49..54804c0 100755
---- a/test_maidenhead.py
-+++ b/test_maidenhead.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- #
- # Test grid locator conversion.
- #
diff --git a/test_misc.py b/test_misc.py
-index 111d8e0..d630771 100755
+index eb79c10..7a81957 100755
--- a/test_misc.py
+++ b/test_misc.py
@@ -1,4 +1,4 @@
@@ -278,6 +238,16 @@ index cb9448e..e1f5301 100755
"""Test imports needed by X11-based tools."""
from __future__ import print_function
+diff --git a/ubxtool b/ubxtool
+index 7e4a042..bab887e 100755
+--- a/ubxtool
++++ b/ubxtool
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: UTF-8
+ '''
+ ubxtool -- u-blox configurator and packet decoder
diff --git a/valgrind-audit.py b/valgrind-audit.py
index 749b2fa..30a1817 100755
--- a/valgrind-audit.py
@@ -289,7 +259,7 @@ index 749b2fa..30a1817 100755
# This is a valgrind torture test for the gpsd daemon.
# It's not really expected to spot anything as long as we aren't using
diff --git a/xgps b/xgps
-index af36225..d231ee5 100755
+index 89d96d1..3edfa6a 100755
--- a/xgps
+++ b/xgps
@@ -1,4 +1,4 @@
@@ -299,7 +269,7 @@ index af36225..d231ee5 100755
'''
xgps -- test client for gpsd
diff --git a/xgpsspeed b/xgpsspeed
-index baada44..a4b0ad4 100755
+index b532fe5..4ce3beb 100755
--- a/xgpsspeed
+++ b/xgpsspeed
@@ -1,4 +1,4 @@
@@ -308,4 +278,13 @@ index baada44..a4b0ad4 100755
#
# by
# Robin Wittler <real@the-real.org> (speedometer mode)
-
+diff --git a/zerk b/zerk
+index 4186042..f0257e6 100755
+--- a/zerk
++++ b/zerk
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: UTF-8
+ '''
+ zerk -- GREIS configurator and packet decoder
diff --git a/main/gpsd/APKBUILD b/main/gpsd/APKBUILD
index 700752407b..d67ee0b728 100644
--- a/main/gpsd/APKBUILD
+++ b/main/gpsd/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Nathan Angelacos <nangel@alpinelinux.org>
# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
pkgname=gpsd
-pkgver=3.19
-pkgrel=1
+pkgver=3.20
+pkgrel=0
pkgdesc="A GPS daemon"
arch=all
url="http://catb.org/gpsd/"
@@ -13,7 +13,6 @@ source="https://download-mirror.savannah.gnu.org/releases/gpsd/$pkgname-$pkgver.
timepps.h
gpsd-use-local-timepps-header.patch
0001-workaround-for-scons-using-python2.patch
- ttydefaults.patch
gpsd.initd
gpsd.confd"
@@ -32,10 +31,12 @@ prepare() {
build() {
cd "$builddir"
- CPPFLAGS="-I. -DHAVE_SYS_TIMEPPS_H"
+ CPPFLAGS="-I. -DHAVE_SYS_TIMEPPS_H"
scons -j${JOBS:-1} \
prefix=/usr \
- target_python=python3
+ target_python=python3 \
+ dbus_export=no \
+ systemd=no
}
check() {
@@ -76,10 +77,9 @@ _clients() {
mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin
}
-sha512sums="c9f9a9ff65759f852771ec4cf97ab15343c9176a149dd5ea6c2e2dc18b47aa7c7bf9ff1f2e8523121564d33a34ae6aa08169c5454847b4fe7848e616fd20a814 gpsd-3.19.tar.gz
+sha512sums="557ef5e5f3b511da4fc441f4bb2e0cd2e23c2981e8b3ce2999973767a04fde070d3ec6f14af60d0e471320078e9f4d1144e5796e7927975ecfbd55fc97f470a9 gpsd-3.20.tar.gz
eb11fc19243d1789016d88eb7645bfe67c46304547781489bf36eb1dd4c252d523681ff835a6488fa0ef62b6b9e2f781c672279f4439f5d5640a3f214a113048 timepps.h
-b918e4b32a6e8bcd25d126e4f1a78dfdda30837a64e7d829f04b27e138843a1dbec83e64677edd6f88eca8cead511949ee664066de4429641ba248fe5a7768ef gpsd-use-local-timepps-header.patch
-a0ec09823247def7b7cc5cdcc123d1ee8d5ab923b1cf7e400b6b8c35b8315e82c70f4d197dab0f3d3cba979c71c20a989617b3ca0725d4f8fa7c99c02f36ca0c 0001-workaround-for-scons-using-python2.patch
-e2af8f52fc2d7e663882b6d12c5f4d709aa267b16eb9aeca2a70d8ecc681ae72359f3efcd1636cde576bc8579e008f242574bc0adfab7252d3e763f039e86135 ttydefaults.patch
+b692c9fc77a9db3fc621693d3b9e3ef9bc2efbbc7b01651168d7b928d29d48a489b8859930bad01b6021e211372e069a726b78dd5938385ed4ae0153b38f4170 gpsd-use-local-timepps-header.patch
+6599951b4df6154de0bc1088f1bc740af68e2b5a1e3ea2b422a406ed54a79d4273a5015e5e4efdf832c8926cb50626fc7fe8be361448128cc63c41b0f8359a70 0001-workaround-for-scons-using-python2.patch
51319247eb78c3021d3eb897cb5d6026cc09d46a532a245a835459ed525947ffb6239f08126dd7e344de52e3b0387226bce060191ec3f14f99fc9f255d96f8ea gpsd.initd
75dbfe39eb900cc9587dd70794ee77ae2230765bbede47760ca227145aa3f2290b6995335ffcfeae6cd86f56b01ca87367548f4fbcf810aff1bc012b7416deef gpsd.confd"
diff --git a/main/gpsd/gpsd-use-local-timepps-header.patch b/main/gpsd/gpsd-use-local-timepps-header.patch
index 5ea6a87626..e7b7642cd1 100644
--- a/main/gpsd/gpsd-use-local-timepps-header.patch
+++ b/main/gpsd/gpsd-use-local-timepps-header.patch
@@ -1,8 +1,8 @@
diff --git a/SConstruct b/SConstruct
-index b8f3fb1..bfe3457 100644
+index 33e0ff3..cf39fd9 100644
--- a/SConstruct
+++ b/SConstruct
-@@ -306,7 +306,7 @@ for var in import_env:
+@@ -319,7 +319,7 @@ for var in import_env:
envs[var] = os.environ[var]
envs["GPSD_HOME"] = os.getcwd()
diff --git a/main/gpsd/ttydefaults.patch b/main/gpsd/ttydefaults.patch
deleted file mode 100644
index 2d0e171265..0000000000
--- a/main/gpsd/ttydefaults.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/gpsmon.c b/gpsmon.c
-index c3001c8..965ea98 100644
---- a/gpsmon.c
-+++ b/gpsmon.c
-@@ -19,6 +19,7 @@
- #include <sys/time.h> /* expected to declare select(2) a la SuS */
- #include <sys/types.h>
- #include <sys/stat.h>
-+#include <sys/ttydefaults.h>
- #include <sys/select.h>
- #include <fcntl.h>
- #include <unistd.h>