aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/devicemaster-linux-vanilla/APKBUILD10
-rw-r--r--main/devicemaster-linux-vanilla/linux-4.19.patch42
2 files changed, 4 insertions, 48 deletions
diff --git a/main/devicemaster-linux-vanilla/APKBUILD b/main/devicemaster-linux-vanilla/APKBUILD
index d175753850..34008854a9 100644
--- a/main/devicemaster-linux-vanilla/APKBUILD
+++ b/main/devicemaster-linux-vanilla/APKBUILD
@@ -2,13 +2,13 @@
# when changing _ver we *must* bump _rel
_name=devicemaster-linux
-_ver=7.28
+_ver=7.34
_rel=0
_flavor=${FLAVOR:-vanilla}
_kpkg=linux-$_flavor
_kver=4.19.78
-_krel=0
+_krel=1
_kpkgver="$_kver-r$_krel"
_kabi="$_kver-$_krel-$_flavor"
@@ -25,8 +25,7 @@ depends="$_kpkg=$_kpkgver"
makedepends="$_kpkg-dev=$_kpkgver linux-headers"
install_if="$_kpkg=$_kpkgver $_name"
# http://downloads.comtrol.com/html/DM_PRO_RTS_SERIALHUB_drivers.htm
-source="https://dev.alpinelinux.org/archive/devicemaster-linux/devicemaster-linux-$_ver.tar.gz
- linux-4.19.patch"
+source="https://dev.alpinelinux.org/archive/devicemaster-linux/devicemaster-linux-$_ver.tar.gz"
builddir="$srcdir"/$_name-$_ver
# grsec legacy
@@ -57,5 +56,4 @@ package() {
cp *.ko "$pkgdir/lib/modules/$_kabi/misc/"
}
-sha512sums="67ca762076e075bb8d0bf9fefbc47df92c4c53018c79977fb575ff6eaeed1d4e97b32b90adf456ec1b3aa301f4a01744f9723232e447ca578afe10192599c9ca devicemaster-linux-7.28.tar.gz
-cb551088201f6405bfc7f4dbdcf815dca03aab9c08ab4b78d3fb4bfff6027d11590db937ec4aaf98a3ab732c4922a1bd09e3e0f4e092d4ffce7b6a6ecdf49e8c linux-4.19.patch"
+sha512sums="a7af54fde5812256b4a04f13d41c064dcb7f702cac18e4929d1a9669c49294eb62fc6e55e7b873bae63a795c3148dbca74ab39f337e26962bdee021f5fb2119c devicemaster-linux-7.34.tar.gz"
diff --git a/main/devicemaster-linux-vanilla/linux-4.19.patch b/main/devicemaster-linux-vanilla/linux-4.19.patch
deleted file mode 100644
index 7a7b2545a0..0000000000
--- a/main/devicemaster-linux-vanilla/linux-4.19.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/nslink.c b/nslink.c
-index 7be65ff..5c7444f 100755
---- a/nslink.c
-+++ b/nslink.c
-@@ -4635,7 +4635,7 @@ static int tcp_txqueue_wait(tTcpTxQueueWait *in)
- #if LINUX_VERSION_CODE < VERSION_CODE(3,15,0)
- static void tcp_data_ready(struct sock *sk, int count)
- #else
--static void tcp_data_ready(struct sock *sk)
-+void tcp_data_ready(struct sock *sk)
- #endif
- {
- struct si_state *si = (struct si_state *)(sk->sk_user_data);
-@@ -5351,19 +5351,6 @@ static int nrp_proc_show(struct seq_file *m, void *v)
- return 0;
- }
-
--static int nrp_proc_open(struct inode *inode, struct file *file)
--{
-- return single_open(file, nrp_proc_show, NULL);
--}
--
--static const struct file_operations nrp_proc_fops = {
-- .owner = THIS_MODULE,
-- .open = nrp_proc_open,
-- .read = seq_read,
-- .llseek = seq_lseek,
-- .release = single_release,
--};
--
- static struct tty_operations nslink_ops = {
- .open = nrp_open,
- .close = nrp_close,
-@@ -5384,7 +5371,7 @@ static struct tty_operations nslink_ops = {
- .wait_until_sent = nrp_wait_until_sent,
- .tiocmget = nrp_tiocmget,
- .tiocmset = nrp_tiocmset,
-- .proc_fops = &nrp_proc_fops,
-+ .proc_show = &nrp_proc_show,
- };
- static const struct tty_port_operations nslink_port_ops = {
- .carrier_raised = nrp_port_carrier_raised,