aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/sent/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/sent/APKBUILD b/community/sent/APKBUILD
index 9be245b7a9..f147b91b2c 100644
--- a/community/sent/APKBUILD
+++ b/community/sent/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=sent
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple plaintext presentation tool"
url="http://tools.suckless.org/sent/"
arch="all"
@@ -12,7 +12,6 @@ depends_dev=""
makedepends="libx11-dev libxft-dev"
install=""
subpackages="$pkgname-doc"
-options="!check" # upstream doesn't have a test suite
source="http://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz
config-mk.patch"
builddir="$srcdir"
@@ -22,6 +21,11 @@ build() {
make -C "$builddir"
}
+check() {
+ cd "$builddir"
+ ./sent -version > /dev/null
+}
+
package() {
cd "$builddir"
make PREFIX="/usr" DESTDIR="$pkgdir" \