aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/varnish/2f2387038a7b9aca4c31c0f839cda3b7ab3391c0.patch31
-rw-r--r--main/varnish/APKBUILD6
2 files changed, 35 insertions, 2 deletions
diff --git a/main/varnish/2f2387038a7b9aca4c31c0f839cda3b7ab3391c0.patch b/main/varnish/2f2387038a7b9aca4c31c0f839cda3b7ab3391c0.patch
new file mode 100644
index 0000000000..66705ded88
--- /dev/null
+++ b/main/varnish/2f2387038a7b9aca4c31c0f839cda3b7ab3391c0.patch
@@ -0,0 +1,31 @@
+From 2f2387038a7b9aca4c31c0f839cda3b7ab3391c0 Mon Sep 17 00:00:00 2001
+From: Guillaume Quintard <guillaume@varnish-software.com>
+Date: Thu, 26 Apr 2018 21:59:41 +0200
+Subject: [PATCH] Fix gensequences for BusyBox awk
+
+I never thought that I'd have to fix a string concatenation problem in
+a BusyBox awk program to generate VT100 code in a container, but here we
+are:
+
+echo | awk 'END {print "foo" "" ++a, "foo" ++a}'
+
+should output "foo0 foo1", and for all the ?awk I tested, it does,
+except for BusyBox awk who thought funny to output "0 foo1", breaking the
+teken_state.h file.
+---
+ bin/varnishtest/gensequences | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bin/varnishtest/gensequences b/bin/varnishtest/gensequences
+index 4337186b8..18a68b43b 100644
+--- a/bin/varnishtest/gensequences
++++ b/bin/varnishtest/gensequences
+@@ -70,7 +70,7 @@ while (getline > 0) {
+ l_prefix_parent[n] = prefix;
+ l_prefix_suffix[n] = sequence[i];
+ if (!l_prefix_name[n])
+- l_prefix_name[n] = "teken_state_" ++npr;
++ l_prefix_name[n] = "teken_state_" "" ++npr;
+ prefix = n;
+ }
+
diff --git a/main/varnish/APKBUILD b/main/varnish/APKBUILD
index 2abba42948..54835013b4 100644
--- a/main/varnish/APKBUILD
+++ b/main/varnish/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: V.Krishn <vkrishn4@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=varnish
-pkgver=6.1.0
+pkgver=6.1.1
pkgrel=0
pkgdesc="High-performance HTTP accelerator"
url="https://www.varnish-cache.org/"
@@ -21,6 +21,7 @@ pkggroups="varnish"
source="https://varnish-cache.org/_downloads/$pkgname-$pkgver.tgz
musl-include-vpf.patch
musl-include-vsb.patch
+ 2f2387038a7b9aca4c31c0f839cda3b7ab3391c0.patch
varnishd.initd
varnishd.confd
@@ -100,9 +101,10 @@ geoip() {
"$subpkgdir"/usr/lib/varnish/plugins/maxminddb.vcl
}
-sha512sums="48584fc2d938cc0759fa5d795992a0c6d5d9fb49db5f3063dca8d3d88c6282dac971ed268edc07bec95b4f25e26562089b1b84abdd26099e12be9ea66557716d varnish-6.1.0.tgz
+sha512sums="67e546e5fee2d10ec038d7b011a3f61a0a056ce8a4813556526c8fce23bb1fe4e29952a773e6cbc2433c0228971a5e90693d5ce61f6cb5f2242e055e0ce13d18 varnish-6.1.1.tgz
2123668169b055f2d88f9b5b8e0877ca8b3cbfcd61e03d91fd7d0513b3267e4ef01a4d858cc6a3298cca0a49aaea2f92ff4fd9c0baf52a6c67b452a53f7e54d0 musl-include-vpf.patch
c51c8964880990c2b01807b2a38d886b146736a918bda9ea2e032c50085bf6745cab3cccb4ee4c561ab936a8b7cfb278cfcb758543ea6c605c15b8973c9f10ce musl-include-vsb.patch
+cee1b98a57d459af4dfb236496d28049cc38719786560480e8847aaa3a8494af2cab6e3d63bd624dafe107afc95b8fcecaf9d355ca07deec4bdc19ffd0d43827 2f2387038a7b9aca4c31c0f839cda3b7ab3391c0.patch
5ac7867e85cbd721f903c524ed4b524423d9dada4acfeefb0e543214a208828df5cc4efe2f012991bea6b38c2b223c24b17d3890ec4ed2c57d2b441b8e5a6900 varnishd.initd
98c8901e53f3c6adb908b9eb01fd441ea53f3c54d4a79aecb1fb1eddfa2fc93de3d0de403a4464a9baff15873b3a20623837e3a37cb225e924a329e32b9e37d6 varnishd.confd
c67a7898f40849989edcbe74e1a418e196f48e178ca30126bc13db226e4f4c2c2ba74d9d0650ef68ed88732917fc06b80ef1f62c2d9d2c14a89f26fd25aed0f7 varnishlog.initd