aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/tilda/APKBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/community/tilda/APKBUILD b/community/tilda/APKBUILD
index d4200bb2f2..cb6257052a 100644
--- a/community/tilda/APKBUILD
+++ b/community/tilda/APKBUILD
@@ -2,29 +2,39 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=tilda
pkgver=1.3.3
-pkgrel=0
+pkgrel=1
pkgdesc="A Gtk based drop down terminal for Linux and Unix"
url="https://github.com/lanoxx/tilda"
arch="all"
license="GPL"
-makedepends="automake autoconf libtool confuse-dev vte3-dev"
+makedepends="automake autoconf libtool
+ confuse-dev vte3-dev libx11-dev libxml2-utils"
subpackages="$pkgname-lang"
source="https://github.com/lanoxx/$pkgname/archive/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgname-$pkgver
-check() {
+prepare() {
cd "$builddir"
- make check
+ NOCONFIGURE=1 ./autogen.sh
+ default_prepare
}
build() {
cd "$builddir"
- ./autogen.sh
./configure \
- --prefix=/usr
+ --prefix=/usr \
+ --disable-maintainer-mode \
+ --enable-lto \
+ --enable-vte-2.91 \
+ --disable-rpath
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="${pkgdir}" install