aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/duplicity/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/main/duplicity/APKBUILD b/main/duplicity/APKBUILD
index 1525a69f8d..daa9b67201 100644
--- a/main/duplicity/APKBUILD
+++ b/main/duplicity/APKBUILD
@@ -2,16 +2,16 @@
# Contributor: Matt Smith <mcs@darkregion.net>
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=duplicity
-pkgver=0.8.08
+pkgver=0.8.12.1612
pkgrel=0
pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
url="http://duplicity.nongnu.org/"
arch="all"
license="GPL-2.0-or-later"
depends="python3 py3-boto gnupg ncftp py3-fasteners py3-future"
-makedepends="python3-dev py3-future py3-setuptools librsync-dev"
+makedepends="python3-dev py3-future py3-setuptools librsync-dev gettext"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://code.launchpad.net/duplicity/${pkgver:0:3}-series/$pkgver/+download/duplicity-$pkgver.tar.gz"
+source="https://launchpad.net/duplicity/0.8-series/${pkgver%.*}/+download/duplicity-$pkgver.tar.gz"
build() {
python3 setup.py build
@@ -19,12 +19,10 @@ build() {
check() {
python3 compilec.py
- # Run a simple smoke-test
- PYTHONPATH="$PWD" python3 bin/duplicity -V | grep -q duplicity
}
package() {
python3 setup.py install --root "$pkgdir"
}
-sha512sums="968ba458b896874ba1af41753927a01446649ea1864128f3a8ac62e31416656e36844ae62a3408e3d82588da3c23929c714bbdb01b6472a80c2f695801985a15 duplicity-0.8.08.tar.gz"
+sha512sums="eac4d1aecd604ece123bd3b5cecd3b65e1213c243db1a3ce25bae58360d666dd1db07ba0a137e7682f99775ece20453c7dc44cd87940b56c0acd05d01149c951 duplicity-0.8.12.1612.tar.gz"