aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/icinga2/APKBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/community/icinga2/APKBUILD b/community/icinga2/APKBUILD
index 157837cb73..9e4bb2d56d 100644
--- a/community/icinga2/APKBUILD
+++ b/community/icinga2/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icinga2
pkgver=2.11.0
-pkgrel=0
+pkgrel=1
pkgdesc="An open source host, service and network monitoring program"
url="http://www.icinga.org"
-arch="all !armhf !armv7"
+arch="all !armhf !armv7 !s390x"
license="GPL"
depends="monitoring-plugins"
makedepends="$depends_dev cmake bison flex boost-dev yajl-dev
@@ -20,17 +20,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pk
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- cd "$builddir"
- mkdir -p build
- default_prepare
-}
-
-check() {
- cd "$builddir"
- make test
-}
-
build() {
cd "$builddir"/build
cmake "$srcdir/$pkgname-$pkgver" \
@@ -52,6 +41,10 @@ build() {
make
}
+check() {
+ make test
+}
+
package() {
cd "$builddir"/build
make DESTDIR="$pkgdir" install