aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libfishsound/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/libfishsound/APKBUILD b/testing/libfishsound/APKBUILD
new file mode 100644
index 0000000000..76a2a486a2
--- /dev/null
+++ b/testing/libfishsound/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=libfishsound
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Simple programming interface for decoding and encoding audio data using the Xiph.org codecs"
+url="https://xiph.org/fishsound/"
+arch="all"
+license="BSD"
+makedepends="libvorbis-dev speex"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="97d850fb42b394fca098a96b1784da431a0af1d54d57127179b612e4b88a7a2e406eb1411f55536e5a11ec2e8956f2659182c60ac46d49f6d14250e39a740339 libfishsound-1.0.0.tar.gz"