aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-pycountry/APKBUILD (renamed from testing/py-pycountry/APKBUILD)12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/py-pycountry/APKBUILD b/testing/py3-pycountry/APKBUILD
index bdb2cb72bc..393de4662c 100644
--- a/testing/py-pycountry/APKBUILD
+++ b/testing/py3-pycountry/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-pycountry
+pkgname=py3-pycountry
_pkgname=pycountry
pkgver=18.12.8
pkgrel=0
@@ -8,19 +8,21 @@ pkgdesc="ISO country, subdivision, language, currency and script definitions and
url="https://pypi.org/project/pycountry"
arch="noarch"
license="LGPL-2.1-or-later"
-depends=""
-makedepends="python2-dev py-lxml py-setuptools"
+provides="py-pycountry" # for backwards compatibility
+replaces="py-pycountry=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+makedepends="python3-dev py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="9797688ada8ea54c1a56a2cf4d0ad765001816c822c40077953fa71e3af285114c4b5beaf739a24432b9c6ea794952ce347a40ae0bcd9a2c00d12ddc7b45261e pycountry-18.12.8.tar.gz"