aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-sphinxcontrib-nwdiag/APKBUILD21
1 files changed, 3 insertions, 18 deletions
diff --git a/testing/py3-sphinxcontrib-nwdiag/APKBUILD b/testing/py3-sphinxcontrib-nwdiag/APKBUILD
index 4154c5fd69..454db27191 100644
--- a/testing/py3-sphinxcontrib-nwdiag/APKBUILD
+++ b/testing/py3-sphinxcontrib-nwdiag/APKBUILD
@@ -4,40 +4,25 @@ pkgname=py3-sphinxcontrib-nwdiag
_pkgname=sphinxcontrib-nwdiag
pkgver=0.9.5
pkgrel=2
-pkgdesc="Sphinx "nwdiag" extension"
+pkgdesc="Sphinx nwdiag extension"
url="https://pypi.python.org/pypi/sphinxcontrib-nwdiag"
arch="noarch"
-license="BSD"
+license="BSD-2-Clause"
depends="py3-nwdiag py3-sphinx"
makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
replaces="py-sphinxcontrib-nwdiag" # for backwards compatibility
provides="py-sphinxcontrib-nwdiag=$pkgver-r$pkgrel" # for backwards compatibility
build() {
- cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="7b5d2db632f446b56601eed8f2bd2025 sphinxcontrib-nwdiag-0.9.5.tar.gz"
-sha256sums="5b0ce78c1f7ccbbf33ca624574b117fa5334c8c17f98306a1e1b30e79db93491 sphinxcontrib-nwdiag-0.9.5.tar.gz"
sha512sums="2c570d4614aa362c43b2f0bcb901f6bca18f91451f50c901805f85f61184e1b531ea5ee2a82b5bca24e34f0a71470b9bdb9057dcaa82cc1c11eb41306561c5c1 sphinxcontrib-nwdiag-0.9.5.tar.gz"