aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-qtpy/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-qtpy/APKBUILD b/testing/py3-qtpy/APKBUILD
new file mode 100644
index 0000000000..5e917ab327
--- /dev/null
+++ b/testing/py3-qtpy/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=py3-qtpy
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="Abstraction layer for several Python interfaces for Qt5"
+url="https://github.com/spyder-ide/qtpy"
+arch="noarch"
+license="MIT"
+depends="python3 py3-qt5"
+makedepends="python3-dev py3-qt5 py3-pytest"
+source="py3-qtpy-$pkgver.tar.gz::https://github.com/spyder-ide/qtpy/archive/v$pkgver.tar.gz"
+builddir="$srcdir/qtpy-$pkgver"
+# TODO: remove this once py3-qt5's a complete package.
+options="!check"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0c971112ec862c7eb37b590e1603b6a8160b58dc6a3618cbb386f2e606a32d490fc21634e08715ff69cd20e2ed5f34ae5b6ee20771a8c84069c42c5116a67641 py3-qtpy-1.3.1.tar.gz"