aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/imlib2/APKBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/main/imlib2/APKBUILD b/main/imlib2/APKBUILD
index ee173def9a..cdfbecfb77 100644
--- a/main/imlib2/APKBUILD
+++ b/main/imlib2/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=imlib2
pkgver=1.4.10
-pkgrel=0
+pkgrel=1
pkgdesc="Library that does image file loading and saving as well as rendering, manipulation, arbitrary polygon support"
url="https://sourceforge.net/projects/enlightenment/"
arch="all"
@@ -23,10 +23,24 @@ build() {
--sysconfdir=/etc/imlib2 \
--x-libraries=/usr/lib \
--disable-mmx \
- --disable-amd64
+ --disable-amd64 \
+ --enable-visibility-hiding \
+ --with-x \
+ --with-bzip2 \
+ --with-gif \
+ --with-id3 \
+ --with-jpeg \
+ --with-png \
+ --with-tiff \
+ --with-zlib
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR=$pkgdir install