aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-locket/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-locket/APKBUILD b/testing/py3-locket/APKBUILD
new file mode 100644
index 0000000000..62694c5207
--- /dev/null
+++ b/testing/py3-locket/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-locket
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="File-based locks for Python"
+url="https://github.com/mwilliamson/locket.py"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://pypi.python.org/packages/source/l/locket/locket-$pkgver.tar.gz"
+options="!check" # Release tarball doesn't contain the tests
+builddir="$srcdir/locket-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ed9bb25f3fcaa70386217716db5612bf31a923c669cbdb8e871de6df4c0c42bf3309604a1aac804c0f334aed8c88b0ba113d8d265054c0e87793c7b53f729ff9 locket-0.2.0.tar.gz"