aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/weston/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/weston/APKBUILD b/testing/weston/APKBUILD
index 99d32b234d..a8a60c1821 100644
--- a/testing/weston/APKBUILD
+++ b/testing/weston/APKBUILD
@@ -7,7 +7,7 @@ _libname=lib$pkgname
_libdir=$_libname-${pkgver%%.*}
pkgdesc="The reference Wayland server"
url="http://wayland.freedesktop.org"
-arch="x86_64 armhf"
+arch="all"
license="MIT"
depends=""
makedepends="wayland-protocols libxkbcommon-dev xkeyboard-config
@@ -29,6 +29,7 @@ subpackages="$pkgname-dev $pkgname-doc $subpackages
"
source="http://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
build() {
cd "$builddir"
@@ -51,6 +52,8 @@ build() {
make
}
+# Does not run through, see also:
+# https://github.com/alpinelinux/aports/pull/1689
check() {
make -C "$builddir" check
return 0