aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/chrome-gnome-shell/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/chrome-gnome-shell/APKBUILD b/testing/chrome-gnome-shell/APKBUILD
new file mode 100644
index 0000000000..5e7b16dfd7
--- /dev/null
+++ b/testing/chrome-gnome-shell/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=chrome-gnome-shell
+pkgver=10.1
+pkgrel=0
+pkgdesc="GNOME Shell integration for WebExtensions capable browsers"
+url="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="py3-requests py3-gobject3"
+makedepends="cmake gettext-dev jq python3"
+options="!check" # No tests available
+source="https://download.gnome.org/sources/chrome-gnome-shell/${pkgver}/chrome-gnome-shell-${pkgver}.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_EXTENSION=FALSE \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f92e98a167e9031cc691d68c668471bf2a9d40b99d740119c7833211b82f33250ea80def912c7725e0b454c1637e9a18c44d0c6f2afd1912ba66bf8f088ec204 chrome-gnome-shell-10.1.tar.xz"