aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/motion/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/testing/motion/APKBUILD b/testing/motion/APKBUILD
index 48f39eb921..dac3a246a2 100644
--- a/testing/motion/APKBUILD
+++ b/testing/motion/APKBUILD
@@ -1,8 +1,9 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=motion
pkgver=3.2.12
-pkgrel=1
+pkgrel=2
pkgdesc="Detect if a significant part of the picture has changed (e.g. from a webcam)."
url="http://www.lavrsen.dk/foswiki/bin/view/Motion/WebHome"
arch="all"
@@ -11,7 +12,7 @@ pkgusers="motion"
pkggroups="motion"
depends="jpeg v4l-utils" # Add ffmpeg (when motion is patched/fixed for this)
depends_dev=""
-makedepends="$depends_dev bash jpeg-dev v4l-utils-dev" # Add ffmpeg-dev (when motion is patched/fixed for this)
+makedepends="$depends_dev bash jpeg-dev v4l-utils-dev linux-headers" # Add ffmpeg-dev (when motion is patched/fixed for this)
install="$pkgname.pre-install"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
@@ -37,8 +38,10 @@ prepare() {
build() {
cd "$_builddir"
./configure \
- --prefix=/usr \
- --sysconfdir=/etc/motion
+ --prefix=/usr \
+ --sysconfdir=/etc/motion \
+ --without-ffmpeg \
+
make || return 1
}