diff options
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 14 |
1 files changed, 10 insertions, 4 deletions
@@ -16,28 +16,28 @@ non-free-pkgs := $(shell ./aport.lua deplist $(rootdir) non-free) unstable-pkgs := $(shell ./aport.lua deplist $(rootdir) unstable) -main: +main: for p in $(main-pkgs) ; \ do \ cd $(rootdir)/$@/$$p; \ abuild -r; \ done -testing: +testing: for p in $(testing-pkgs) ; \ do \ cd $(rootdir)/$@/$$p; \ abuild -r; \ done -non-free: +non-free: for p in $(non-free-pkgs) ; \ do \ cd $(rootdir)/$@/$$p; \ abuild -r; \ done -unstable: +unstable: for p in $(unstable-pkgs) ; \ do \ cd $(rootdir)/$@/$$p; \ @@ -51,6 +51,12 @@ clean: abuild cleanpkg; \ done +cleanold: + for p in $(all-pkgs) ; do \ + cd $(rootdir)/$$p; \ + abuild cleanoldpkg; \ + done + fetch: for p in $(all-pkgs) ; do \ cd $(rootdir)/$$p; \ |