aboutsummaryrefslogtreecommitdiffstats
path: root/community/astyle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/astyle/APKBUILD')
-rw-r--r--community/astyle/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/astyle/APKBUILD b/community/astyle/APKBUILD
new file mode 100644
index 0000000000..6796ff37a0
--- /dev/null
+++ b/community/astyle/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=astyle
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="An automatic code formatter"
+url="http://sourceforge.net/projects/astyle"
+arch="all"
+license="LGPL"
+source="http://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz"
+builddir="$srcdir/$pkgname/build/gcc"
+
+build() {
+ cd "$builddir"
+ make release
+}
+
+check() {
+ cd "$builddir"
+ # upstream do not provide tests
+ ./bin/astyle --version
+}
+
+package() {
+ cd "$builddir"
+ install -Dm0755 bin/astyle "$pkgdir/usr/bin/astyle"
+}
+
+sha512sums="3e8d617c0ec89682bfb076081bb63ae9d44e897de0c85d5109b28adbbfe0620d5dacf59a4bd96ac30a5a4fcb3be136758e9c6fe2c69258b37956c212890a7158 astyle_3.0.1_linux.tar.gz"