aboutsummaryrefslogtreecommitdiffstats
path: root/community/atools
diff options
context:
space:
mode:
Diffstat (limited to 'community/atools')
-rw-r--r--community/atools/APKBUILD8
-rw-r--r--community/atools/escape-bare-underscore.patch13
2 files changed, 18 insertions, 3 deletions
diff --git a/community/atools/APKBUILD b/community/atools/APKBUILD
index b05367cc97..1ad701b73e 100644
--- a/community/atools/APKBUILD
+++ b/community/atools/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=atools
-pkgver=12
+pkgver=15.1
pkgrel=0
pkgdesc="Auxilary scripts for abuild"
url="https://github.com/maxice8/atools"
@@ -11,7 +11,8 @@ depends="grep"
makedepends="scdoc redo"
checkdepends="bats"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/maxice8/atools/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/maxice8/atools/archive/$pkgver.tar.gz
+ escape-bare-underscore.patch"
build() {
redo build
@@ -25,4 +26,5 @@ package() {
DESTDIR="$pkgdir" redo install
}
-sha512sums="ccbbd3d305acf6143e996cb626b3bbd0a839ab20e972e8b2ddd4fa75b365920cf51b3688c637d86bb1a43466deccf62caaebd673594faa34c00470de2221abea atools-12.tar.gz"
+sha512sums="c56f3370d0fedc1df3d6e20bdf05f58046935d1b9238d963fa65edfc2acc6579b4122a1453428de2689c99f623d450ba0382318ae2f01e0956240bfbffa3f0de atools-15.1.tar.gz
+5c85b9fe41210538647b277081cade8cc265f5e2a9f2d7e1707194d7afd2be5c3c56ab29e364a6af3ca6f2c4ccdbffe632e572303f52518a621af3bf990fd2d8 escape-bare-underscore.patch"
diff --git a/community/atools/escape-bare-underscore.patch b/community/atools/escape-bare-underscore.patch
new file mode 100644
index 0000000000..86a229f515
--- /dev/null
+++ b/community/atools/escape-bare-underscore.patch
@@ -0,0 +1,13 @@
+diff --git a/alint.5.scd b/alint.5.scd.new
+index efbd41745c..5df881665d 100644
+--- a/alint.5.scd
++++ b/alint.5.scd.new
+@@ -278,7 +278,7 @@ Severity: Serious, Certainty: Certain
+
+ ## _builddir-is-set [AL26]
+
+-_builddir is set instead of builddir, which is an old variable from before builddir
++\_builddir is set instead of builddir, which is an old variable from before builddir
+ existed as a concept understood by abuild
+
+ Severity: Serious, Certainty: Certain