aboutsummaryrefslogtreecommitdiffstats
path: root/community/bcc/20-install-static.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/bcc/20-install-static.patch')
-rw-r--r--community/bcc/20-install-static.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/community/bcc/20-install-static.patch b/community/bcc/20-install-static.patch
new file mode 100644
index 0000000000..3e56c66098
--- /dev/null
+++ b/community/bcc/20-install-static.patch
@@ -0,0 +1,18 @@
+diff --git a/src/cc/CMakeLists.txt b/src/cc/CMakeLists.txt
+index c4675dee..2bb97395 100644
+--- a/src/cc/CMakeLists.txt
++++ b/src/cc/CMakeLists.txt
+@@ -145,6 +145,7 @@ if(LIBBPF_FOUND)
+ endif()
+
+ install(TARGETS bcc-shared LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(TARGETS bcc-static LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ install(FILES ${bcc_table_headers} DESTINATION include/bcc)
+ install(FILES ${bcc_api_headers} DESTINATION include/bcc)
+ install(DIRECTORY ${libbpf_uapi} DESTINATION include/bcc/compat/linux FILES_MATCHING PATTERN "*.h")
+@@ -152,3 +153,5 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libbcc.pc DESTINATION ${CMAKE_INSTALL_
+ endif(ENABLE_CLANG_JIT)
+ install(FILES ${bcc_common_headers} DESTINATION include/bcc)
+ install(TARGETS bccbpf-shared LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(TARGETS bccbpf-static LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(TARGETS bcc-loader-static LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})