aboutsummaryrefslogtreecommitdiffstats
path: root/community/bluedevil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bluedevil/APKBUILD')
-rw-r--r--community/bluedevil/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/bluedevil/APKBUILD b/community/bluedevil/APKBUILD
index 693e4d1b31..c4f83e6403 100644
--- a/community/bluedevil/APKBUILD
+++ b/community/bluedevil/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=bluedevil
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="Integrate the Bluetooth technology within KDE workspace and applications"
arch="all"
@@ -9,11 +9,18 @@ url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends="kded bluez"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kwidgetsaddons-dev kdbusaddons-dev knotifications-dev kwindowsystem-dev kiconthemes-dev plasma-framework-dev ki18n-dev kio-dev bluez-qt-dev kded-dev kded shared-mime-info"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/bluedevil-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -21,11 +28,13 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="de3c767413ede046ef39bc249c728c50f22db04ce1062956f9462214cf0d9dda0468ea3e463330663da720226a97b3bf935c5c138d282d066181faf0b6e55828 bluedevil-5.16.5.tar.xz"
+sha512sums="ee7304d693e02c0a3309bef9b9ef759ff436bbbea190235bb01d1f2e49f6173114b6329ebfbdb5584a0ae34d6beaec7d2ebf8c9bb970797ac8c47bdca2899765 bluedevil-5.17.0.tar.xz"