aboutsummaryrefslogtreecommitdiffstats
path: root/community/cargo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cargo/APKBUILD')
-rw-r--r--community/cargo/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/cargo/APKBUILD b/community/cargo/APKBUILD
index fdd002b5ce..10539dcc8e 100644
--- a/community/cargo/APKBUILD
+++ b/community/cargo/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=cargo
pkgver=0.22.0
-pkgrel=0
+pkgrel=1
pkgdesc="The Rust package manager"
url="https://crates.io"
arch="x86_64" # limited by rust pkg
@@ -22,7 +22,7 @@ subpackages="$pkgname-doc
# adhere to this file and verify checksums. So it provides the same
# guarantees as abuild. That said, for now it's exception only for cargo
# package and should not be applied to other rust packages!
-_bootstrap_cargo_ver=0.18.0
+_bootstrap_cargo_ver=0.17.0
source="$pkgname-$pkgver.tar.gz::https://github.com/rust-lang/$pkgname/archive/$pkgver.tar.gz
https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_bootstrap_cargo_ver-x86_64-alpine-linux-musl.tar.gz
tests-fix-build-auth-http_auth_offered.patch
@@ -36,6 +36,7 @@ _cargo_opts="--release --locked --verbose ${JOBS:+--jobs $JOBS}"
# Uploaded cargo binary from the built package to dev.a.o, so it can be used
# for building cargo next time (needed for bootstrapping).
+# TODO: Build statically linked binary for bootstrapping!
snapshot() {
local apkfile="$REPODEST/$repo/$CARCH/$pkgname-$pkgver-r$pkgrel.apk"
local tarname="$pkgname-$pkgver-$CHOST"
@@ -104,6 +105,6 @@ zshcomp() {
}
sha512sums="31764df0462fcd0e7ddd29aee63ed0916b0d05e44d72aa815b3b823256e90f85e582c468a517d048e4451dfc1a3b22434abf25d825d3d926ab7a95f7bb44ad40 cargo-0.22.0.tar.gz
-25ef1cca46e2167a01a96359991eb4f3eef73de08c693be1f36b5256c0e445fa0630f61a366c2e3f55df936034392886297c5204a35d1712a6865d8d31dab51a cargo-0.18.0-x86_64-alpine-linux-musl.tar.gz
+b78a03942344852fd1a8c0ac893580c589757d4946150e5959e1df08b163b94ce5319236a48506c18f987cf3500a2c7cfe808eef13092c45d271e169946a18d1 cargo-0.17.0-x86_64-alpine-linux-musl.tar.gz
4e9a0d409951a72b5c1d3578cb310c0efc5d98a5b963432ec4f485f1d58d2354f0050c31574d6bd9090b7247468ef1a13b04b133deabe6daed91032764468f97 tests-fix-build-auth-http_auth_offered.patch
17c669a71443e21cc5e5cc6eb99933c20562b7df9d859c493ff25252167eb1aea6dd7322a06207776eab1c769464f95a432d1520a949512a52592b1eb115a4be tests-ignore-ssh_something_happens.patch"