aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot/remove-check-for-setuptools-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/certbot/remove-check-for-setuptools-version.patch')
-rw-r--r--community/certbot/remove-check-for-setuptools-version.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/community/certbot/remove-check-for-setuptools-version.patch b/community/certbot/remove-check-for-setuptools-version.patch
new file mode 100644
index 0000000000..7d8d0711eb
--- /dev/null
+++ b/community/certbot/remove-check-for-setuptools-version.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/setup.py
+index 84c27fc..97b0606 100644
+--- a/setup.py
++++ b/setup.py
+@@ -58,11 +58,11 @@ install_requires = [
+ # However environment markers are supported only with setuptools >= 36.2.
+ # So this dependency is not added for old Linux distributions with old setuptools,
+ # in order to allow these systems to build certbot from sources.
+-if StrictVersion(setuptools_version) >= StrictVersion('36.2'):
+- install_requires.append("pywin32 ; sys_platform == 'win32'")
+-elif 'bdist_wheel' in sys.argv[1:]:
+- raise RuntimeError('Error, you are trying to build certbot wheels using an old version '
+- 'of setuptools. Version 36.2+ of setuptools is required.')
++#if StrictVersion(setuptools_version) >= StrictVersion('36.2'):
++# install_requires.append("pywin32 ; sys_platform == 'win32'")
++#elif 'bdist_wheel' in sys.argv[1:]:
++# raise RuntimeError('Error, you are trying to build certbot wheels using an old version '
++# 'of setuptools. Version 36.2+ of setuptools is required.')
+
+ dev_extras = [
+ 'astroid==1.6.5',