aboutsummaryrefslogtreecommitdiffstats
path: root/community/chicken/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/chicken/APKBUILD')
-rw-r--r--community/chicken/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/chicken/APKBUILD b/community/chicken/APKBUILD
index ba687d1ada..e84f89b614 100644
--- a/community/chicken/APKBUILD
+++ b/community/chicken/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=chicken
pkgver=4.12.0
-pkgrel=0
+pkgrel=1
pkgdesc="R5RS and R7RS compatible scheme compiler and interpreter"
url="http://call-cc.org/"
arch="all"
@@ -27,6 +27,11 @@ build() {
-C "$builddir" || return 1
}
+check() {
+ make -j1 PLATFORM=linux \
+ -C "$builddir" check || return 1
+}
+
package() {
# chicken does not support parallel installs.
make -j1 PLATFORM=linux PREFIX=/usr DESTDIR="$pkgdir" \