aboutsummaryrefslogtreecommitdiffstats
path: root/community/chntpw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/chntpw/APKBUILD')
-rw-r--r--community/chntpw/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/community/chntpw/APKBUILD b/community/chntpw/APKBUILD
index ccc782e195..dfb11a891b 100644
--- a/community/chntpw/APKBUILD
+++ b/community/chntpw/APKBUILD
@@ -2,20 +2,26 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=chntpw
pkgver=140201
-pkgrel=2
+pkgrel=3
pkgdesc="Change passwords in Windows SAM files"
url="http://pogostick.net/~pnh/ntpasswd/"
arch="all"
options="!check"
license="GPL-2.0"
-makedepends="openssl-dev"
+makedepends=""
source="http://pogostick.net/~pnh/ntpasswd/$pkgname-source-$pkgver.zip
- stdint.patch"
+ stdint.patch
+ chntpw-080526-correct-test-for-failing-open-syscall.patch
+ chntpw-110511-detect-failure-to-write-key.patch
+ chntpw-110511-reged-no-deref-null.patch
+ chntpw-110511-robustness.patch
+ chntpw-140201-get_abs_path.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- make CC="${CC:-gcc}" CFLAGS="$CFLAGS -DUSEOPENSSL" LIBS="-lcrypto" \
+ make CC="${CC:-gcc}" CFLAGS="$CFLAGS" \
chntpw cpnt reged
}
@@ -25,9 +31,10 @@ package() {
install chntpw cpnt reged "$pkgdir"/usr/bin/
}
-md5sums="d60bc657206b07ad84d926649d6417dc chntpw-source-140201.zip
-7219b4f860212e85de39ba1937e2c296 stdint.patch"
-sha256sums="96e20905443e24cba2f21e51162df71dd993a1c02bfa12b1be2d0801a4ee2ccc chntpw-source-140201.zip
-9d392cdf598d4a9e9ddd3ae1b538ed1d8bd63fb27e23d4e4c9b13110b808a723 stdint.patch"
sha512sums="a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa chntpw-source-140201.zip
-3ed747119d125b3e4dc8dbb2a697d411ef2f4403ec84c60177d8e35389bc695bb0c65f7aa4314ca320ffceec87e60e2a0c81d52544b90463fe23aa7d4a50df67 stdint.patch"
+3ed747119d125b3e4dc8dbb2a697d411ef2f4403ec84c60177d8e35389bc695bb0c65f7aa4314ca320ffceec87e60e2a0c81d52544b90463fe23aa7d4a50df67 stdint.patch
+1332407858eb20e0f1304472bc458789ef78638059137b91ff0b7bac9619740e8a608aace0330ace363853b5c02642fdbbc66bc47dac19f6807dae57cdaca4ca chntpw-080526-correct-test-for-failing-open-syscall.patch
+a570451f52943a2ccdced349c5fe4e82e1a338dd6d0067ddaf18dc328b2c3ee3976d08827eee866b4654ccbda93ad95dcbabaddd0b6487a1e4112b66fc63bde1 chntpw-110511-detect-failure-to-write-key.patch
+c61ea69ea1f039e470f501fddd1d3674ee7427e9084361a1aba03402d302a07efd1a2630e16f479bd3cef13b17e85c14cbfff53cb33bccb470465276b1b7ac22 chntpw-110511-reged-no-deref-null.patch
+bcc314545272b5be04612e435a2f9dd13cbf065cfbd80aed2ed57147ee9e73b2478cd18e95cbaa7ad3b5dfcf4788a3026b5ddd767f89ea9c80ba7a2efc7ea8c4 chntpw-110511-robustness.patch
+1bb5939d2cfd3718b9e630998b250c3c37d50d5769463f4f8456ede9fa4521e1bf9d9f05986883df36418d91bef591b34a81cd36bfacca053160e4d95c03cb4b chntpw-140201-get_abs_path.patch"