aboutsummaryrefslogtreecommitdiffstats
path: root/community/colord/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/colord/APKBUILD')
-rw-r--r--community/colord/APKBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/community/colord/APKBUILD b/community/colord/APKBUILD
index bc4f252f1b..5794aa6985 100644
--- a/community/colord/APKBUILD
+++ b/community/colord/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=colord
-pkgver=1.4.3
+pkgver=1.4.4
pkgrel=0
pkgdesc="System daemon for managing color devices"
url="http://www.freedesktop.org/software/colord"
@@ -9,16 +9,15 @@ arch="all"
license="GPL-2.0"
pkgusers="colord"
pkggroups="colord"
-depends=""
depends_dev="dconf-dev dbus-dev gobject-introspection-dev sqlite-dev
polkit-dev eudev-dev libgudev-dev"
makedepends="$depends_dev meson ninja intltool bash-completion libgusb-dev lcms2-dev"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://www.freedesktop.org/software/colord/releases/colord-$pkgver.tar.xz"
+source="https://www.freedesktop.org/software/colord/releases/colord-$pkgver.tar.xz
+ disable-udev-hwdb-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
mkdir build && cd build
meson --prefix=/usr \
--sysconfdir=/etc \
@@ -35,9 +34,20 @@ build() {
ninja
}
+check() {
+ cd build
+
+ # cd-private-test is broken atm
+ # meson test
+
+ src/cd-self-test
+}
+
package() {
- cd "$builddir/build"
+ cd build
+
DESTDIR="$pkgdir" ninja install
}
-sha512sums="8a4dc9c6c480cff0a3a9d9187e087cc07e1c8c262edd45cbb69e51d384fab4331b1115c354ee2160ab36137b7d342fb450672acd29066dd45e7878562197dce2 colord-1.4.3.tar.xz"
+sha512sums="0187a363c41ae5102dc3b454fcd84df83d71ac0dc32d88b33651edc1df15cbf1f47218caee3037c876e892613a2301226886a73b39759cfb709d0fef8e168628 colord-1.4.4.tar.xz
+4e306254902658ffe0904b4ee3fdc10c473af909662c08fc66b9070fd698e07e1f804e53ccd94160ac57d268269132683808ff8f2bae64fd2a9070d6f024b800 disable-udev-hwdb-tests.patch"