aboutsummaryrefslogtreecommitdiffstats
path: root/community/corehunt
diff options
context:
space:
mode:
Diffstat (limited to 'community/corehunt')
-rw-r--r--community/corehunt/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/corehunt/APKBUILD b/community/corehunt/APKBUILD
new file mode 100644
index 0000000000..309f70c52b
--- /dev/null
+++ b/community/corehunt/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
+# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
+pkgname=corehunt
+pkgver=2.7.1
+pkgrel=0
+pkgdesc="A file finder utility from the CoreApps family."
+arch="all"
+url="https://gitlab.com/cubocore"
+license="GPL-3.0-or-later"
+depends="qt5-qtsvg"
+makedepends="qt5-qtbase-dev libcprime-dev"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/corehunt/-/archive/v$pkgver/corehunt-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+options="!check"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+sha512sums="4f550d887f68c26d3f3995dace5baed7942614545f00616010751fcf366b37c2c1e6e824dbd96b43730fa6619274aa4fd42d04953d23ffbec96a68d520279746 corehunt-2.7.1.tar.gz"