aboutsummaryrefslogtreecommitdiffstats
path: root/community/corestats
diff options
context:
space:
mode:
Diffstat (limited to 'community/corestats')
-rw-r--r--community/corestats/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/corestats/APKBUILD b/community/corestats/APKBUILD
new file mode 100644
index 0000000000..434506c71d
--- /dev/null
+++ b/community/corestats/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
+# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
+pkgname=corestats
+pkgver=2.7.0
+pkgrel=0
+pkgdesc="A system resource viewer from the CoreApps family."
+arch="all"
+url="https://gitlab.com/cubocore"
+license="GPL-3.0-or-later"
+depends="qt5-qtsvg"
+makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+options="!check"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+sha512sums="739ca35e421cf790eb396399e8294fdb296523adacb9b9f6c35aefbcf4402eb1fd0fcb9ce16f1fafd242b88d822a52c9e072fc2e916807355efee499a95bc34d corestats-2.7.0.tar.gz"