aboutsummaryrefslogtreecommitdiffstats
path: root/community/crystal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/crystal/APKBUILD')
-rw-r--r--community/crystal/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/crystal/APKBUILD b/community/crystal/APKBUILD
index ead238a8f3..452036cdb6 100644
--- a/community/crystal/APKBUILD
+++ b/community/crystal/APKBUILD
@@ -8,8 +8,7 @@ _bootver=0.31.1
_llvmver=8
pkgdesc="The Crystal Programming Language"
url="https://crystal-lang.org/"
-# TODO(mps): skip colorize test
-arch="" # aarch64 disabled, details in #11017
+arch="x86_64" # aarch64 disabled, details in #11017
license="Apache-2.0"
depends="gc-dev libatomic_ops libevent-dev libevent-static gcc gmp-dev pcre-dev"
checkdepends="openssl-dev libxml2-dev readline-dev tzdata yaml-dev zlib-dev"
@@ -24,6 +23,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/crystal-lang/$pkgname/archiv
fix-std-xml-spec.cr.patch
fix-version-string.patch
fix-std-http-cookie-exp.patch
+ fix-spec-colorize.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -110,6 +110,7 @@ zshcomp() {
depends=""
install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ cd "$builddir"
install -D -m 644 etc/completion.zsh \
"$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
@@ -119,4 +120,5 @@ sha512sums="d83575f4c7953054824f13516cdc04bd7576bf7165754d96a9f4970e2a6cbf779b4d
ee1d81b40a9b15b2abfecbc61a1ef830700cc5613f9d2626722e8393633ed5d40329ac1fc2813b08b66c689876d3bd8a9f949a22beeda572ea3d4753f58417a8 fix-spec-std-kernel-spec.cr.patch
dabfb0ca7859785dd1ed75f5eaea7a7c25b09a61d7c9c81f4cbac4ece7dc475d531ce9fd6d1002db9ec5d7067051ea34fd77ab590c2c733034f430c89229cfa9 fix-std-xml-spec.cr.patch
1bb7d649841a7b0f66fdebbb75647ef8958ce7fb3437f0a6303ad21750af79becdcad87ddcf9353d48d466495a6c5837171b571a46412fd746c741296a67ad93 fix-version-string.patch
-4fd246be702982a012c3092e1742a5b80566b6d43888f9c09b25c27efcb56f5417a77234b5d36ebdcf89c5ad3a0571ca717ab26ed833c05497a4bf12328fcf17 fix-std-http-cookie-exp.patch"
+4fd246be702982a012c3092e1742a5b80566b6d43888f9c09b25c27efcb56f5417a77234b5d36ebdcf89c5ad3a0571ca717ab26ed833c05497a4bf12328fcf17 fix-std-http-cookie-exp.patch
+2a52f81c36c85f138fa7f59483fe417e7fc01bc38b1d4061b37487a2d17c2a698b89813b51c43c6fc6bb65b1b0aa8f108427f85e86fe59fe97a3e6e075cdac54 fix-spec-colorize.patch"