aboutsummaryrefslogtreecommitdiffstats
path: root/community/dep/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dep/APKBUILD')
-rw-r--r--community/dep/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/dep/APKBUILD b/community/dep/APKBUILD
new file mode 100644
index 0000000000..eb6f81e564
--- /dev/null
+++ b/community/dep/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Ed Robinson <edward-robinson@cookpad.com>
+# Maintainer: Ed Robinson <edward-robinson@cookpad.com>
+pkgname=dep
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="Go dependency management tool"
+url="https://github.com/golang/dep"
+arch="all"
+license="BSD-3-Clause"
+makedepends="go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/golang/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+builddir="$srcdir/src/github.com/golang/$pkgname"
+
+prepare() {
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+ default_prepare
+}
+
+build() {
+ export GOPATH="$srcdir"
+ cd "$builddir"
+ go build -ldflags="-X main.version=$pkgver" -o ./bin/dep ./cmd/dep
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 ./bin/dep "$pkgdir"/usr/bin/dep
+}
+
+check() {
+ cd "$builddir"
+ ./bin/dep status > /dev/null
+}
+
+sha512sums="29caef5dbbb21020f4ba4024b9c8601da5c7f9f8caa5ab63c6dfa927be2140d33037473600246f35a6e58f94bad592b1974c38b8b9fec6f4d1d68ec8324db3d2 dep-0.4.1.tar.gz"