aboutsummaryrefslogtreecommitdiffstats
path: root/community/discount/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/discount/APKBUILD')
-rw-r--r--community/discount/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/discount/APKBUILD b/community/discount/APKBUILD
new file mode 100644
index 0000000000..b9bd1a3555
--- /dev/null
+++ b/community/discount/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=discount
+pkgver=2.2.2
+pkgrel=0
+pkgdesc="A Markdown to HTML translator written in C"
+url="http://www.pell.portland.or.us/~orc/Code/discount/"
+arch="all"
+license="BSD"
+depends="!markdown"
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.pell.portland.or.us/~orc/Code/discount/$pkgname-$pkgver.tar.bz2
+ configure.inc.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure.sh \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-all-features \
+ --with-fenced-code \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install install.man || return 1
+}
+
+sha512sums="67d882c0a334592230332815c543458b3c916a950bf7983f8a468fbc9f61154b4023d4bf451b76639fcb3a076506b48118f192a8e21f2535b3f49c7f081bbdf3 discount-2.2.2.tar.bz2
+d243f0b5e01cd91376fa94960e9abcdbf24d3579f7d4b5220262e867adefdc5e9ed850fe0228cc290ed605f4b42c50a5ce1ac3fb61ff191a24dc2349d16b2ff2 configure.inc.patch"