aboutsummaryrefslogtreecommitdiffstats
path: root/community/dnsdist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dnsdist/APKBUILD')
-rw-r--r--community/dnsdist/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/dnsdist/APKBUILD b/community/dnsdist/APKBUILD
index 32820f5d97..63a159e727 100644
--- a/community/dnsdist/APKBUILD
+++ b/community/dnsdist/APKBUILD
@@ -9,6 +9,7 @@ arch="all"
license="GPL2"
_lua_version="5.1"
depends="$pkgname-common !$pkgname-luajit"
+checkdepends="findutils"
makedepends="boost-dev fstrm-dev libedit-dev libsodium-dev lua${_lua_version}-dev net-snmp-dev protobuf-dev re2-dev"
pkgusers="dnsdist"
pkggroups="dnsdist"
@@ -72,15 +73,21 @@ build() {
make
}
+_cat_found_file() {
+ local _rc="$?"
+ find -name "$1" -type f -ls -printf '%P {{{\n' -exec cat -v -n '{}' ';' -printf '}}} %P\n'
+ return "$_rc"
+}
+
check() {
cd "$builddir"
- make check
+ make check || _cat_found_file 'test-suite.log'
./dnsdist --version
[ -d "$builddir-jit" ] || return 0
cd "$builddir-jit"
- make check
+ make check || _cat_found_file 'test-suite.log'
./dnsdist --version
}