aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dolphin/APKBUILD')
-rw-r--r--community/dolphin/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/dolphin/APKBUILD b/community/dolphin/APKBUILD
index 8627db3bc9..1cf8cae9c3 100644
--- a/community/dolphin/APKBUILD
+++ b/community/dolphin/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=dolphin
-pkgver=19.08.2
+pkgver=19.08.3
pkgrel=0
arch="all"
url="https://kde.org/applications/system/dolphin"
@@ -15,11 +15,18 @@ depends_dev="qt5-qtbase-dev kdoctools-dev kinit-dev kcmutils-dev knewstuff-dev
phonon-dev baloo-dev baloo-widgets-dev kfilemetadata-dev kactivities-dev"
makedepends="$depends_dev extra-cmake-modules ruby-test-unit"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/dolphin-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -27,12 +34,14 @@ build() {
}
check() {
+ cd "$builddir"/build
# kfileitemmodeltest and placesitemmodeltest are broken
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(kfileitemmodel|placesitemmodel)test"
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="97ba07fc6e5f7295297149b8377620c0fb9dedec33833671f29e39f8cb4fb78051bd21d7d63b1dfc48126b03195b3eecc831c3882346a86fbb6ff1122996cbbc dolphin-19.08.2.tar.xz"
+sha512sums="4390f97398b437b24f0139982e068e32a042a0740790b7dbf19747cd77b41c70dd04f0c6ba3120775f8ce48f43bdd3d2cff4590ba5556773950dd73dd9f7aad0 dolphin-19.08.3.tar.xz"