aboutsummaryrefslogtreecommitdiffstats
path: root/community/duo_unix/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/duo_unix/APKBUILD')
-rw-r--r--community/duo_unix/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/duo_unix/APKBUILD b/community/duo_unix/APKBUILD
index 8ea50ffb48..5a6ed67af5 100644
--- a/community/duo_unix/APKBUILD
+++ b/community/duo_unix/APKBUILD
@@ -2,19 +2,23 @@
# Maintainer: Paul Morgan <jumanjiman@gmail.com>
pkgname=duo_unix
pkgver=1.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="duosecurity.com two-factor authentication"
url="https://duo.com/support/documentation/duounix"
arch="all"
license="GPL-2.0"
depends=""
depends_dev="libressl-dev zlib-dev"
-makedepends="$depends_dev"
+makedepends="$depends_dev automake autoconf libtool"
options="suid"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://dl.duosecurity.com/$pkgname-$pkgver.tar.gz"
+source="https://github.com/duosecurity/duo_unix/archive/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgname-$pkgver
-builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ ./bootstrap
+}
build() {
cd "$builddir"
./configure \
@@ -32,4 +36,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="45e246e7665e8d9c70ce43eed632371b079e9aec20f6c5d771a7d1de80a0f75d987fb88002de719358511d92d05b27824e539af53836af75a0939e59aae37359 duo_unix-1.10.1.tar.gz"
+sha512sums="2d87846273740036dcb5d61db28c9262b1869eedfad3d4ffc0f1bb1942f91acadf847e7714d961de5c5d23680ae9471ab94a4c1d3b09d0a9334a76cbcf481e39 duo_unix-1.10.1.tar.gz"