aboutsummaryrefslogtreecommitdiffstats
path: root/community/dvdauthor
diff options
context:
space:
mode:
Diffstat (limited to 'community/dvdauthor')
-rw-r--r--community/dvdauthor/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/dvdauthor/APKBUILD b/community/dvdauthor/APKBUILD
new file mode 100644
index 0000000000..8e5f89afa8
--- /dev/null
+++ b/community/dvdauthor/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=dvdauthor
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="DVD authoring tools"
+url="http://dvdauthor.sourceforge.net"
+arch="all"
+license="GPL"
+makedepends="libpng-dev freetype-dev libdvdread-dev
+ fribidi-dev libxml2-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname"
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-rpath \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
+}
+
+sha512sums="202b8bba38939d122dc864921a57e89906ca99ddabf44e3b07419cc42cc052567cd892b41f1171c9c195c9a770758e9319a942ea64d14ee8fa847588c7761125 dvdauthor-0.7.2.tar.gz"