aboutsummaryrefslogtreecommitdiffstats
path: root/community/elasticsearch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/elasticsearch/APKBUILD')
-rw-r--r--community/elasticsearch/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/elasticsearch/APKBUILD b/community/elasticsearch/APKBUILD
index 4f269b4d7c..b0039855cf 100644
--- a/community/elasticsearch/APKBUILD
+++ b/community/elasticsearch/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=elasticsearch
pkgver=6.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="Open Source, Distributed, RESTful Search Engine"
url="https://www.elastic.co/products/elasticsearch"
arch="x86 x86_64 ppc64le"
@@ -89,6 +89,13 @@ package() {
install -m644 -D "$srcdir"/README.alpine \
"$docdir"
+
+ # Enforce plugins directory relocation
+ # Passing the "path.plugins" or "es.default.path.plugins" arguments
+ # at runtime does not seem to work in v6.4,
+ # it generates an exception if "$destdir"/plugins does not exist.
+ # The plugins directory will be shared among all ES instances.
+ ln -s /var/lib/elasticsearch/_default/plugins "$destdir"/plugins
}
_builtin_module() {