aboutsummaryrefslogtreecommitdiffstats
path: root/community/fractal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fractal/APKBUILD')
-rw-r--r--community/fractal/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/community/fractal/APKBUILD b/community/fractal/APKBUILD
index 2539df41e5..72fc9ac44a 100644
--- a/community/fractal/APKBUILD
+++ b/community/fractal/APKBUILD
@@ -5,7 +5,7 @@ pkgver=4.2.1
pkgrel=0
pkgdesc="Matrix group messaging app"
url="https://wiki.gnome.org/Apps/Fractal"
-arch="x86_64 armhf armv7 aarch64 ppc64le" # limited by Rust
+arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by Rust
license="GPL-3.0-or-later"
makedepends="meson gtk+3.0-dev dbus-dev openssl-dev gspell-dev libhandy-dev
gtksourceview4-dev gstreamer-dev gst-plugins-base-dev gst-plugins-bad-dev
@@ -14,6 +14,12 @@ options="!check" # no tests
subpackages="$pkgname-lang"
source="https://gitlab.gnome.org/GNOME/fractal/-/archive/$pkgver/fractal-$pkgver.tar.gz"
+case "$CARCH" in
+ x86)
+ export CFLAGS="$CFLAGS -fno-stack-protector"
+ ;;
+esac
+
build() {
meson \
--prefix=/usr \