aboutsummaryrefslogtreecommitdiffstats
path: root/community/frameworkintegration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/frameworkintegration/APKBUILD')
-rw-r--r--community/frameworkintegration/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/frameworkintegration/APKBUILD b/community/frameworkintegration/APKBUILD
index 8e69c1474c..54985521fe 100644
--- a/community/frameworkintegration/APKBUILD
+++ b/community/frameworkintegration/APKBUILD
@@ -1,20 +1,27 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=frameworkintegration
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
arch="all"
url="https://www.kde.org"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev kconfig-dev kconfigwidgets-dev kiconthemes-dev knotifications-dev knewstuff-dev kwidgetsaddons-dev kpackage-dev ki18n-dev"
+depends_dev="qt5-qtbase-dev kconfig-dev kconfigwidgets-dev kiconthemes-dev knotifications-dev knewstuff-dev kwidgetsaddons-dev kpackage-dev ki18n-dev appstream-dev"
makedepends="$depends_dev extra-cmake-modules"
checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -22,11 +29,13 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="918ecb9ddf50cfa8b8fce3fb218a8b80a97d3e440e3c6faf5bb76e74ff1752448244da19da0367a6e077ee8f7e4599328da667d63d45c35490a0a7436570e336 frameworkintegration-5.62.0.tar.xz"
+sha512sums="76edf9191fad80c19f5bc2bc40e91b16583219bf4dd79c0a722089195ef0325f95a6863723cbc7e1c46446d978ff812ce13afb78bd47fc0b96e0fe26f8716ea4 frameworkintegration-5.63.0.tar.xz"