aboutsummaryrefslogtreecommitdiffstats
path: root/community/fvwm
diff options
context:
space:
mode:
Diffstat (limited to 'community/fvwm')
-rw-r--r--community/fvwm/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/fvwm/APKBUILD b/community/fvwm/APKBUILD
index d9083b5848..891b7f7ca2 100644
--- a/community/fvwm/APKBUILD
+++ b/community/fvwm/APKBUILD
@@ -18,21 +18,23 @@ source="https://github.com/fvwmorg/fvwm/releases/download/$pkgver/$pkgname-$pkgv
builddir=$srcdir/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--disable-perllib \
--disable-bidi \
--disable-rsvg \
- --disable-xinerama \
- --disable-gtk \
- --with-gnome=no \
- || return 1
+ --disable-xinerama
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="127cd1cc68e98e673056c1dd5108dfabc7560cfc98c86e35b95d75c6327156389f77aa0470e2e6f702865367f29d3bd1cfa8cf07a5b1c1693fa6e04fb2af717f fvwm-2.6.7.tar.gz"