aboutsummaryrefslogtreecommitdiffstats
path: root/community/fwupd/fix-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/fwupd/fix-version.patch')
-rw-r--r--community/fwupd/fix-version.patch28
1 files changed, 11 insertions, 17 deletions
diff --git a/community/fwupd/fix-version.patch b/community/fwupd/fix-version.patch
index 37e6759dd4..be4a369c6f 100644
--- a/community/fwupd/fix-version.patch
+++ b/community/fwupd/fix-version.patch
@@ -1,17 +1,11 @@
-get_version_git() uses git describe which describes the aports repo, it is supposed to fail and use get_version() instead
-
-diff --git a/contrib/get-version.py b/contrib/get-version.py
-index 0a678ca..f6fe0d7 100755
---- a/contrib/get-version.py
-+++ b/contrib/get-version.py
-@@ -39,9 +39,4 @@ def get_version():
-
- if __name__ == '__main__':
-
-- version = get_version_git()
-- if version:
-- version = sanitize_for_ci(version)
-- else:
-- version = get_version()
-- print(version)
-+ print(get_version())
+diff --git a/meson.build b/meson.build
+index 959fc0d..0251e0c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,5 +1,5 @@
+ project('fwupd', 'c',
+- version : run_command('contrib/get-version.py').stdout().strip(),
++ version : '1.3.5',
+ license : 'LGPL-2.1+',
+ meson_version : '>=0.47.0',
+ default_options : ['warning_level=2', 'c_std=c99'],