aboutsummaryrefslogtreecommitdiffstats
path: root/community/fzf/disable-vet-for-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/fzf/disable-vet-for-tests.patch')
-rw-r--r--community/fzf/disable-vet-for-tests.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/fzf/disable-vet-for-tests.patch b/community/fzf/disable-vet-for-tests.patch
new file mode 100644
index 0000000000..328b80277e
--- /dev/null
+++ b/community/fzf/disable-vet-for-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 5f68100828..123bfe9974 100644
+--- a/Makefile
++++ b/Makefile
+@@ -102,7 +102,7 @@ vendor: $(GLIDE_YAML)
+ touch $@
+
+ test: $(SOURCES) vendor
+- SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" \
++ SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" -vet=off \
+ github.com/junegunn/fzf/src \
+ github.com/junegunn/fzf/src/algo \
+ github.com/junegunn/fzf/src/tui \