aboutsummaryrefslogtreecommitdiffstats
path: root/community/geth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geth/APKBUILD')
-rw-r--r--community/geth/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/geth/APKBUILD b/community/geth/APKBUILD
new file mode 100644
index 0000000000..a8031c2ea9
--- /dev/null
+++ b/community/geth/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=geth
+pkgver=1.6.6
+pkgrel=0
+pkgdesc="Official Go implementation of the Ethereum protocol"
+url="https://geth.ethereum.org/"
+arch="all"
+license="LGPLv3"
+makedepends="go linux-headers"
+checkdepends="fuse"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz"
+builddir="$srcdir/go-ethereum"-$pkgver
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "${pkgdir}"/usr/bin
+ install -m755 -t "${pkgdir}"/usr/bin build/bin/*
+}
+
+sha512sums="edc08b328cd56f4fc8aafa58782c8b54ac9b20827c6591c8b771d3f6400fa6b03ab131c4b5767181972f1a374fb118ad607a4a3cc1c3c86546159c5b9b8cc841 geth-1.6.6.tar.gz"