aboutsummaryrefslogtreecommitdiffstats
path: root/community/gjs
diff options
context:
space:
mode:
Diffstat (limited to 'community/gjs')
-rw-r--r--community/gjs/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/gjs/APKBUILD b/community/gjs/APKBUILD
new file mode 100644
index 0000000000..0d457dadc1
--- /dev/null
+++ b/community/gjs/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gjs
+pkgver=1.58.5
+pkgrel=0
+pkgdesc="GNOME javascript library"
+url="https://wiki.gnome.org/Projects/Gjs"
+arch="all !s390x"
+license="MIT LGPL-2.0-or-later"
+makedepends="$depends_dev dbus gobject-introspection-dev mozjs60-dev mozjs60
+ gtk+3.0-dev cairo-dev"
+checkdepends="xvfb-run"
+options="!check" # testCommandLine.sh fails
+subpackages="$pkgname-dev"
+source="https://download.gnome.org/sources/gjs/${pkgver%.*}/gjs-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-profiler
+ make
+}
+
+check() {
+ xvfb-run make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="18ef3afc4403ed281e1e70a379fd68ffa537ffc20ab66d7faaefe51e03bb6a66e359e5ca2c0511e1c5f8c6adfce93601d011cfb9e9e6b0a18f8aa1f2398297c3 gjs-1.58.5.tar.xz"