aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-power-manager
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-power-manager')
-rw-r--r--community/gnome-power-manager/APKBUILD42
-rw-r--r--community/gnome-power-manager/execinfo.patch26
-rw-r--r--community/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch30
-rw-r--r--community/gnome-power-manager/gnome-power-manager.post-install7
-rw-r--r--community/gnome-power-manager/gnome-power-manager.post-upgrade7
-rw-r--r--community/gnome-power-manager/gnome-power-manager.pre-deinstall7
6 files changed, 15 insertions, 104 deletions
diff --git a/community/gnome-power-manager/APKBUILD b/community/gnome-power-manager/APKBUILD
index 33a52bce0e..dd5628d9e4 100644
--- a/community/gnome-power-manager/APKBUILD
+++ b/community/gnome-power-manager/APKBUILD
@@ -1,43 +1,31 @@
-# Contributor:
-# Maintainer:
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-power-manager
-pkgver=3.30.0
+pkgver=3.32.0
pkgrel=0
pkgdesc="GNOME power manager"
-url="http://www.gnome.org"
+url="https://gitlab.gnome.org/GNOME/gnome-power-manager"
arch="all"
-license="GPL"
-makedepends="intltool gobject-introspection-dev
- upower-dev gtk+3.0-dev meson"
+license="GPL-2.0-or-later"
+makedepends="intltool gobject-introspection-dev upower-dev gtk+3.0-dev meson"
subpackages="$pkgname-lang"
-install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
source="https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
-builddir="${srcdir}/${pkgname}-${pkgver}"
-
-prepare() {
- default_prepare
- cd "$builddir"
- mkdir -p build
-}
-
-check() {
- cd "$builddir"/build
- ninja test
-}
build() {
- cd "$builddir"/build
meson \
--prefix=/usr \
--buildtype=release \
- --sysconfdir=/etc ..
- ninja
+ --sysconfdir=/etc \
+ output .
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
}
package() {
- cd "$builddir"/build
- export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="ed0e2a20bd8979fd9064cea9f4485da832eb44a2c727e39cde5ca9f9e2eb75a37e3d1b5a2181d9c666c19b1b300cbc62cd5f9e2c3f36ee4a4dfc3e1537a10329 gnome-power-manager-3.30.0.tar.xz"
+sha512sums="0ea11085dd015e30c1bdc6913000b63eabf7df76720f2d51d63b075f3b7bd2a610aaa484c53a4092d78d3c484ed8c4e81ec66603bdc6c132b0316113ec6a24a0 gnome-power-manager-3.32.0.tar.xz"
diff --git a/community/gnome-power-manager/execinfo.patch b/community/gnome-power-manager/execinfo.patch
deleted file mode 100644
index c9def1be10..0000000000
--- a/community/gnome-power-manager/execinfo.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- gnome-power-manager-2.32.0.orig/src/egg-debug.c
-+++ gnome-power-manager-2.32.0/src/egg-debug.c
-@@ -39,7 +39,6 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <time.h>
--#include <execinfo.h>
-
- #include "egg-debug.h"
-
-@@ -78,6 +77,7 @@
- void
- egg_debug_backtrace (void)
- {
-+#if 0
- void *call_stack[512];
- int call_stack_size;
- char **symbols;
-@@ -95,6 +95,7 @@
- pk_set_console_mode (CONSOLE_RESET);
- free (symbols);
- }
-+#endif
- }
-
- /**
diff --git a/community/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch b/community/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch
deleted file mode 100644
index 022d2c5fe5..0000000000
--- a/community/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- ./src/gpm-manager.c
-+++ ./src/gpm-manager.c
-@@ -43,6 +43,10 @@
- #include <libupower-glib/upower.h>
- #include <libnotify/notify.h>
-
-+#ifndef NOTIFY_CHECK_VERSION
-+#define NOTIFY_CHECK_VERSION(x,y,z) 0
-+#endif
-+
- #include "egg-debug.h"
- #include "egg-console-kit.h"
-
-@@ -480,12 +484,16 @@
- /* close any existing notification of this class */
- gpm_manager_notify_close (manager, *notification_class);
-
-+#if NOTIFY_CHECK_VERSION (0, 7, 0)
-+ notification = notify_notification_new (title, message, icon);
-+#else
- /* if the status icon is hidden, don't point at it */
- if (manager->priv->status_icon != NULL &&
- gtk_status_icon_is_embedded (manager->priv->status_icon))
- notification = notify_notification_new_with_status_icon (title, message, icon, manager->priv->status_icon);
- else
- notification = notify_notification_new (title, message, icon, NULL);
-+#endif
- notify_notification_set_timeout (notification, timeout);
- notify_notification_set_urgency (notification, urgency);
- g_signal_connect (notification, "closed", G_CALLBACK (gpm_manager_notification_closed_cb), notification_class);
diff --git a/community/gnome-power-manager/gnome-power-manager.post-install b/community/gnome-power-manager/gnome-power-manager.post-install
deleted file mode 100644
index 8d6b50a50e..0000000000
--- a/community/gnome-power-manager/gnome-power-manager.post-install
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-for i in gnome-power-manager.schemas; do
- echo "Installing GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
-done
diff --git a/community/gnome-power-manager/gnome-power-manager.post-upgrade b/community/gnome-power-manager/gnome-power-manager.post-upgrade
deleted file mode 100644
index 8d6b50a50e..0000000000
--- a/community/gnome-power-manager/gnome-power-manager.post-upgrade
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-for i in gnome-power-manager.schemas; do
- echo "Installing GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
-done
diff --git a/community/gnome-power-manager/gnome-power-manager.pre-deinstall b/community/gnome-power-manager/gnome-power-manager.pre-deinstall
deleted file mode 100644
index ed1e2c420a..0000000000
--- a/community/gnome-power-manager/gnome-power-manager.pre-deinstall
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-for i in gnome-power-manager.schemas; do
- echo "Uninstalling GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
-done