aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnuchess
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnuchess')
-rw-r--r--community/gnuchess/APKBUILD10
-rw-r--r--community/gnuchess/uclibc.patch14
2 files changed, 2 insertions, 22 deletions
diff --git a/community/gnuchess/APKBUILD b/community/gnuchess/APKBUILD
index 128aea8afd..2f7beb91ff 100644
--- a/community/gnuchess/APKBUILD
+++ b/community/gnuchess/APKBUILD
@@ -8,13 +8,9 @@ url="https://www.gnu.org/software/chess/"
arch="all"
license="GPL-3.0-or-later"
subpackages="$pkgname-doc"
-source="https://ftp.gnu.org/gnu/chess/gnuchess-$pkgver.tar.gz
- uclibc.patch
- "
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://ftp.gnu.org/gnu/chess/gnuchess-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,9 +23,7 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="f3f65a85eb4c93f6f10c7058bde7ee7f4a48c2f465b24a7cc0d5bcafe4df186b434ce23bf8c032d012efffba39c6c3c60ada484ff22d87114ce2be5dd0da6835 gnuchess-6.2.5.tar.gz
-3f42fdcccfeab43f2e47ae599aee19a76a9e4b6af41f68456d30d8520fb410c689f2d56aae06c0588bea9b38e5aa508fb992cfc913906b6e5911d7f9d60bd9fc uclibc.patch"
+sha512sums="f3f65a85eb4c93f6f10c7058bde7ee7f4a48c2f465b24a7cc0d5bcafe4df186b434ce23bf8c032d012efffba39c6c3c60ada484ff22d87114ce2be5dd0da6835 gnuchess-6.2.5.tar.gz"
diff --git a/community/gnuchess/uclibc.patch b/community/gnuchess/uclibc.patch
deleted file mode 100644
index 53721da3d7..0000000000
--- a/community/gnuchess/uclibc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./lib/gettext.h.orig 2013-11-18 08:27:03.257572285 +0000
-+++ ./lib/gettext.h 2013-11-18 08:28:02.271566431 +0000
-@@ -50,9 +50,9 @@
- /* Many header files from the libstdc++ coming with g++ 3.3 or newer include
- <libintl.h>, which chokes if dcgettext is defined as a macro. So include
- it now, to make later inclusions of <libintl.h> a NOP. */
--#if defined(__cplusplus) && defined(__GNUG__) && (__GNUC__ >= 3)
-+#if defined(__cplusplus) && defined(__GNUG__) && (__GNUC__ >= 3) && !defined (__UCLIBC__)
- # include <cstdlib>
--# if (__GLIBC__ >= 2 && !defined __UCLIBC__) || _GLIBCXX_HAVE_LIBINTL_H
-+# if (__GLIBC__ >= 2) || _GLIBCXX_HAVE_LIBINTL_H
- # include <libintl.h>
- # endif
- #endif