aboutsummaryrefslogtreecommitdiffstats
path: root/community/gvm-libs/000-fortify-source.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/gvm-libs/000-fortify-source.patch')
-rw-r--r--community/gvm-libs/000-fortify-source.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/gvm-libs/000-fortify-source.patch b/community/gvm-libs/000-fortify-source.patch
new file mode 100644
index 0000000000..26ceb25ca9
--- /dev/null
+++ b/community/gvm-libs/000-fortify-source.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a85088f..9d47f3a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -302,7 +302,7 @@ if (NOT MINGW)
+
+ endif (NOT MINGW)
+
+-set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
++set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
+ set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
+
+