aboutsummaryrefslogtreecommitdiffstats
path: root/community/gwenhywfar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gwenhywfar/APKBUILD')
-rw-r--r--community/gwenhywfar/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/community/gwenhywfar/APKBUILD b/community/gwenhywfar/APKBUILD
new file mode 100644
index 0000000000..04c1ac9c4f
--- /dev/null
+++ b/community/gwenhywfar/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=gwenhywfar
+pkgver=4.18.0
+_pkgrel=206
+pkgrel=0
+pkgdesc="Multi-platform helper library"
+url="http://www.aquamaniac.de/"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev=""
+makedepends="libgcrypt-dev gnutls-dev gettext-dev
+ automake autoconf libtool bash"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://www.aquamaniac.de/sites/download/download.php?package=01&release=${_pkgrel}&file=01&dummy=$pkgname-$pkgver.tar.gz
+ libintl.patch
+ fix-tests.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ autoreconf -vfi
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-guis= \
+ --enable-ssl \
+ --enable-visibility
+ make
+}
+
+check() {
+ make -C "$builddir" check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ install -m644 AUTHORS ChangeLog README TODO \
+ "$pkgdir"/usr/share/doc/$pkgname
+}
+
+sha512sums="3225a6eb06c8a0e53433b0cbac75818521664f2449905847747a4808d54ffaf3dfe597e71666accea28f5fc69f582f0e35942b128c7c96e788eed6e03ab894b4 gwenhywfar-4.18.0.tar.gz
+fcccf5aa3872f4327205c3c77c5e1b88fbce89d6fe45330f72a38c207b7f6166ca486e70636119a9c16447a3c09e3bad97ed7a1cc5f06db53939f510e2c19cca libintl.patch
+62a127684b5d0900edf3f78b884285e63ea43d076b03c265cb59834e915fb68be61601bd54a6c991b20e793d511a5826fde22312e3fe3b2686d993cf32dd3869 fix-tests.patch"