aboutsummaryrefslogtreecommitdiffstats
path: root/community/httpie/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/httpie/APKBUILD')
-rw-r--r--community/httpie/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/httpie/APKBUILD b/community/httpie/APKBUILD
new file mode 100644
index 0000000000..e0850c843e
--- /dev/null
+++ b/community/httpie/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=httpie
+pkgver=0.9.8
+pkgrel=0
+pkgdesc="A CLI, cURL-like tool"
+url="https://github.com/jkbr/httpie"
+arch="noarch"
+license="BSD"
+depends="python3 py3-requests py3-pygments"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="67f8dd48003d01bd339617da1426c487553c998b2d5082ae6ad3833d7eaff31e610ebb8c87f2a62cf4685df111b8a6c6b2e7229290b82945132cfb5c647ca9a1 httpie-0.9.8.tar.gz"