aboutsummaryrefslogtreecommitdiffstats
path: root/community/hugo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hugo/APKBUILD')
-rw-r--r--community/hugo/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/hugo/APKBUILD b/community/hugo/APKBUILD
new file mode 100644
index 0000000000..968ea49976
--- /dev/null
+++ b/community/hugo/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=hugo
+pkgver=0.18
+pkgrel=0
+pkgdesc="A Fast and Flexible Static Site Generator built with love in GoLang"
+url="http://gohugo.io/"
+arch="all"
+license="Apache 2.0"
+depends=""
+makedepends="go govendor"
+install=""
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/spf13/hugo/archive/v$pkgver.tar.gz"
+builddir="$srcdir/src/github.com/spf13/$pkgname"
+
+prepare() {
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/ || return 1
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ export GOPATH="$srcdir"
+ govendor sync -v || return 1
+ go build -v -o bin/$pkgname || return 1
+}
+
+package() {
+ install -Dm755 "$builddir"/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+md5sums="f8b829b348ab7ea85c467631c6552fb0 hugo-0.18.tar.gz"
+sha256sums="9d432f53018d642526a44f9182b6584a4be83810dcd6ebc13e7a44c015ae35a0 hugo-0.18.tar.gz"
+sha512sums="b55a9e75a9d71fab2882d1eb923861dad0f504b219bcd9c6d5dd8a81fdb7509355cbb2ce692a488dc8b7439166772cd40563742234182e5e66c320906145583f hugo-0.18.tar.gz"