aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3wm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/i3wm/APKBUILD')
-rw-r--r--community/i3wm/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/i3wm/APKBUILD b/community/i3wm/APKBUILD
new file mode 100644
index 0000000000..87959f9dcd
--- /dev/null
+++ b/community/i3wm/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=i3wm
+pkgver=4.12
+pkgrel=1
+pkgdesc="A tiling window manager"
+url="http://i3wm.org"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev bison flex libxcb-dev xcb-util-cursor-dev
+ xcb-util-keysyms-dev xcb-util-wm-dev libev-dev pango-dev cairo-dev
+ yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://i3wm.org/downloads/i3-${pkgver}.tar.bz2
+ musl.patch"
+
+builddir="$srcdir/i3-$pkgver"
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install || return 1
+
+ install -d "$pkgdir/usr/share/man/man1"
+ install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/ || return 1
+}
+
+md5sums="308fc79ed252e1f3c8a093598e13e326 i3-4.12.tar.bz2
+aa998beb0b9a83d2910508768ac7faae musl.patch"
+sha256sums="e19e1ce08c2549cba83e083cc768d487202c41760d5c283f67752e791f1d78b4 i3-4.12.tar.bz2
+b7d084c53addc71fda13ccb8b3dcca2a32d9ca1590a28bf3be1a0c61870d3817 musl.patch"
+sha512sums="966f62dbd82c6c70d1344cc61f14f154f3f649ce1b5a5b5168f00f50d598582ef26f5bd5496ea62e13213e45b1c7043f6209c94fcbefe2947fec63284445c1f5 i3-4.12.tar.bz2
+8ce7d00371c43b93dabbe0dadf9caf7c58a68f4a0079f5a9b9552c15c55bfa0df16d7e87a281595af2ac5254632ba28ccf82a467cea16159b41490f6f2910299 musl.patch"